Sharepoint data sources errors

Incident Report for Tonkean

Postmortem

We experienced a disruption to its SharePoint integration between May 14–15, 2026, caused by the expiration of authentication credentials used to connect to Microsoft SharePoint services. The issue affected customers using our shared SharePoint integration, causing failed SharePoint actions during the outage window. The first authentication failures were logged on May 14 at approximately 19:37 UTC. The incident was formally reported on May 15 at 17:28 UTC following the identification of multiple customer issues.
Investigation began at 17:45 UTC, and expired Azure AD client secrets were identified as the root cause. Updated credentials were generated and deployed beginning at 18:01 UTC. Additional remediation steps and environment restarts were completed between 18:05 and 18:10 UTC to ensure the updated credentials were fully applied. Customers confirmed successful reconnection to SharePoint integrations following the fix.
To reduce the likelihood of recurrence, we are enhancing our monitoring and alerting for credential expiration, expanding audits of integration authentication across environments, refining credential rotation procedures, and continuing efforts to further automate integration credential management workflows.

Posted May 17, 2026 - 07:42 PDT

Resolved

This incident has been resolved.
Posted May 15, 2026 - 12:26 PDT

Update

We are continuing to monitor for any further issues.
Posted May 15, 2026 - 08:41 PDT

Monitoring

A fix was implemented and we are currently monitoring the situation.
Posted May 15, 2026 - 08:30 PDT

Identified

We discovered an error with Sharepoint data sources breaking due to an invalid key error. We found the root cause and are working on a fix.
Posted May 15, 2026 - 08:14 PDT
This incident affected: Data Sources (Webhooks, Data Collection & Actions).